<!doctype html>
<html lang="en-US">
	<head>
		<meta charset="UTF-8">
		<meta name="viewport" content="width=device-width, initial-scale=1">
		<link rel="profile" href="https://gmpg.org/xfn/11">
		<title>NFL schedule Week 15: TV coverage, channels, scores for every football game today &#8211; The Hamden Journal</title>
<meta name='robots' content='max-image-preview:large' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Hamden Journal &raquo; Feed" href="https://www.thehamdenjournal.com/feed/" />
		<!-- This site uses the Google Analytics by MonsterInsights plugin v8.3.0 - Using Analytics tracking - https://www.monsterinsights.com/ -->
							<script src="//www.googletagmanager.com/gtag/js?id=UA-214923119-1"  type="text/javascript" data-cfasync="false" data-wpfc-render="false" async></script>
			<script type="text/javascript" data-cfasync="false" data-wpfc-render="false">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</script>
				<!-- / Google Analytics by MonsterInsights -->
				<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.1.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.thehamdenjournal.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.8.2"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([10084,65039,8205,55357,56613],[10084,65039,8203,55357,56613])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://www.thehamdenjournal.com/wp-includes/css/dist/block-library/style.min.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='mpp_gutenberg-css'  href='https://www.thehamdenjournal.com/wp-content/plugins/metronet-profile-picture/dist/blocks.style.build.css?ver=2.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp_automatic_gallery_style-css'  href='https://www.thehamdenjournal.com/wp-content/plugins/wp-automatic/css/wp-automatic.css?ver=1.0.0' type='text/css' media='all' />
<link rel='stylesheet' id='everest-news-style-css'  href='https://www.thehamdenjournal.com/wp-content/themes/everest-news/style.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='everest-news-fonts-css'  href='//fonts.googleapis.com/css?family=Muli%3A400%2C400i%2C600%2C700%2C700i%7COpen%2BSans%3A400%2C400i%2C600%2C700%2C700i&#038;subset=latin%2Clatin-ext&#038;ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='everest-news-main-css'  href='https://www.thehamdenjournal.com/wp-content/themes/everest-news/assets/dist/css/main.css?ver=5.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='tmm-css'  href='https://www.thehamdenjournal.com/wp-content/plugins/team-members/inc/css/tmm_style.css?ver=5.8.2' type='text/css' media='all' />
<script type='text/javascript' id='monsterinsights-frontend-script-js-extra'>
/* <![CDATA[ */
var monsterinsights_frontend = {"js_events_tracking":"true","download_extensions":"doc,pdf,ppt,zip,xls,docx,pptx,xlsx","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/www.thehamdenjournal.com","hash_tracking":"false","ua":"UA-214923119-1","v4_id":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.thehamdenjournal.com/wp-content/plugins/google-analytics-for-wordpress/assets/js/frontend-gtag.min.js?ver=8.3.0' id='monsterinsights-frontend-script-js'></script>
<script type='text/javascript' src='https://www.thehamdenjournal.com/wp-includes/js/jquery/jquery.min.js?ver=3.6.0' id='jquery-core-js'></script>
<script type='text/javascript' src='https://www.thehamdenjournal.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script>
<script type='text/javascript' src='https://www.thehamdenjournal.com/wp-content/plugins/wp-automatic/js/main-front.js?ver=5.8.2' id='wp_automatic_gallery-js'></script>
<link rel="https://api.w.org/" href="https://www.thehamdenjournal.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.thehamdenjournal.com/wp-json/wp/v2/posts/1521" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.thehamdenjournal.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.thehamdenjournal.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.8.2" />
<link rel='shortlink' href='https://www.thehamdenjournal.com/?p=1521' />
<link rel="alternate" type="application/json+oembed" href="https://www.thehamdenjournal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thehamdenjournal.com%2Fsports%2Fnfl-schedule-week-15-tv-coverage-channels-scores-for-every-football-game-today%2F1521%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.thehamdenjournal.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.thehamdenjournal.com%2Fsports%2Fnfl-schedule-week-15-tv-coverage-channels-scores-for-every-football-game-today%2F1521%2F&#038;format=xml" />
		<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
				<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload, .lazyloading { opacity: 0; }
				.lazyloaded {
					opacity: 1;
					transition: opacity 400ms;
					transition-delay: 0ms;
				}
					</style>
				<noscript>
			<style>
				img.lazyload {
				 	display: none;
				}

				img.image-fallback {
				 	display: block;
				}
			</style>
		</noscript>
		<style>
			.primary-navigation li.primarynav_search_icon {
							}
			#toTop {
							}

							.copyright-notice a,
				.social-icons-list li a:hover,
				.social-icons-list-post-page li:first-child,
				.en-author-box .author-name h3,
				.page-404-entry .header-404 h3 span,
				.widget_rss ul li a,
				.event-page-top-box .event-metas ul p {
					color: #ED1D25;
				}

				.en-breaking-news .ticker-head-col span,
				.owl-carousel .owl-nav button.owl-next, 
				.owl-carousel .owl-nav button.owl-prev,
				ul.post-categories li a,
				.widget-title:after,
				.en-custom-category ul li a,
				.btn-general,
				.en-popular-trending-posts-widget-1 ul.tabs li.current,
				#toTop,
				#header-search input[type=submit], 
				.search-box input[type=submit], 
				.widget_search input[type=submit],
				.en-pagination .pagi-layout-1 .nav-links span.current,
				.header-lay-2 .main-navigation .home-btn a, 
				.header-lay-3 .main-navigation .home-btn a,
				button, 
				input[type=button], 
				input[type=reset], 
				input[type=submit],
				.calendar_wrap caption,
				.live-feeds-entry .live-feed .leftbox span,
				.en-popular-trending-posts-widget-1 .content-holder .left-col span {
					background-color: #ED1D25;
				}

				ul.post-categories li a:before,
				.en-breaking-news .ticker-head-col span:before {
					border-top-color: #ED1D25;
				}

				.header-lay-2 .main-navigation, 
				.header-lay-3 .main-navigation {
					border-bottom-color: #ED1D25;
				}

				.post-page-layout-1 .page-title h2,
				.post-format.quote-format blockquote {
					border-left-color: #ED1D25;
				}
						</style>
			</head>

	<body class="post-template-default single single-post postid-1521 single-format-standard">
				
		<div class="en-pagewrap">

			<header class="en-general-header header-lay-2 en-standard-section-spacing">
    <div class="header-inner">
                    <div class="header-top-wrapper">
                <div class="en-container">
                    <div class="en-row">
                        <div class="en-col category-nav-col">
                            <div class="category-navigation">
                                <ul id="menu-about-menu" class="menu"><li id="menu-item-159" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-159"><a href="https://www.thehamdenjournal.com/">Home</a></li>
<li id="menu-item-110" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-110"><a href="https://www.thehamdenjournal.com/about-us/">About Us</a></li>
<li id="menu-item-113" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113"><a href="https://www.thehamdenjournal.com/team-members/">Team Members</a></li>
<li id="menu-item-7" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7"><a href="https://www.thehamdenjournal.com/contact/">Contact</a></li>
<li id="menu-item-109" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-109"><a href="https://www.thehamdenjournal.com/privacy-policy/">Privacy Policy</a></li>
<li id="menu-item-111" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-111"><a href="https://www.thehamdenjournal.com/cookie-policy/">Cookie Policy</a></li>
<li id="menu-item-112" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112"><a href="https://www.thehamdenjournal.com/editorial-policy/">Editorial Policy</a></li>
</ul>                            </div><!-- .category-navigation -->
                        </div><!-- .en-col.category-nav-col -->
                        <div class="en-col social-col">
                            		<ul class="social-icons-list">
			        </ul><!-- .social-icons-list -->
		                        </div><!-- .en-col.social-col -->
                    </div><!-- .en-row -->
                </div><!-- .en-container -->
            </div><!-- .header-top-wrapper -->
                    <div class="header-logo-advt-wrapper">
            <div class="en-container">
                <div class="en-row">
                    <div class="en-col logo-col">
                         		<div class="branding-col">
            				<span class="site-title"><a href="https://www.thehamdenjournal.com/" rel="home">The Hamden Journal</a></span>
				        </div><!-- .branding-col -->
 		                    </div><!-- .en-col.logo-col -->
                                    </div><!-- .en-row.advt-col -->
            </div><!-- .en-container -->
        </div><!-- .header-logo-advt-wrapper -->

        <div class="header-nav-extra-wrapper">
            <div class="en-container">
                <div class="en-row">
                    <div class="en-col nav-col">
                        <div class="primary-menu-wrap">
                            <div class="main-navigation" id="main-menu">
                                <ul id="menu-main-menu" class=""><li class="home-btn"><a href="https://www.thehamdenjournal.com/"><i class="fas fa-home"></i></a></li><li id="menu-item-50" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-50"><a href="https://www.thehamdenjournal.com/us/">US</a></li>
<li id="menu-item-51" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-51"><a href="https://www.thehamdenjournal.com/world/">World</a></li>
<li id="menu-item-47" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-47"><a href="https://www.thehamdenjournal.com/business/">Business</a></li>
<li id="menu-item-48" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-48"><a href="https://www.thehamdenjournal.com/science/">Science</a></li>
<li id="menu-item-49" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-49"><a href="https://www.thehamdenjournal.com/technology/">Technology</a></li>
</ul>                            </div><!-- #main-menu.main-navigation -->
                                                            <div class="header-search">
                                    <a id="search-toggle" href="javascript:;"><i class="icon ion-ios-search"></i></a>
                                    <div id="header-search">
                                        <form role="search" method="get" id="search-form" class="clearfix" action="https://www.thehamdenjournal.com/"><input type="search" name="s" placeholder="Type Something" value"" ><input type="submit" id="submit" value="Search"></form>                                    </div><!-- .header_search -->
                                </div><!-- .header-search -->
                                                        </div><!-- .primary-menu-wrap -->
                    </div><!-- .en-col.nav-col -->
                </div><!-- .en-row -->
            </div><!-- .en-container -->
        </div><!-- .header-nav-extra-wrapper -->
    </div><!-- .header-inner -->
</header><!-- .en-general-header.header-lay-2.en-standard-section-spacing -->            <div id="canvas-aside">
                <div class="canvas-inner">
                                    </div><!-- .canvas-inner -->
            </div><!-- #canvas-aside -->
            <div id="canvas-aside-mask"></div>
            <div class="en-inner-pages-main-wrapper columns-2">
    <div class="en-container">
         			<div class="en-breadcrumb breadcrumb-layout-1 en-standard-section-spacing">
                <nav role="navigation" aria-label="Breadcrumbs" class="breadcrumb-trail breadcrumbs" itemprop="breadcrumb"><ul class="trail-items" itemscope itemtype="http://schema.org/BreadcrumbList"><meta name="numberOfItems" content="3" /><meta name="itemListOrder" content="Ascending" /><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-begin"><a href="https://www.thehamdenjournal.com" rel="home" itemprop="item"><span itemprop="name">Home</span></a><meta itemprop="position" content="1" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item"><a href="https://www.thehamdenjournal.com/sports/" itemprop="item"><span itemprop="name">Sports</span></a><meta itemprop="position" content="2" /></li><li itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem" class="trail-item trail-end"><a href="#" itemprop="item"><span itemprop="name">NFL schedule Week 15: TV coverage, channels, scores for every football game today</span></a><meta itemprop="position" content="3" /></li></ul></nav>            </div><!-- .en-breadcrumb.breadcrumb-layout-1.en-standard-section-spacing -->
 			        <div class="row">
                        <div class="en-col main-content-area-outer ">
                <div id="primary" class="content-area">
                    <main id="main" class="site-main">
                    	<section class="en-page-entry post-page-entry post-page-layout-1">
    <article id="post-1521" class="post-1521 post type-post status-publish format-standard has-post-thumbnail hentry category-sports">
        <div class="page-title">
            <h2 class="clr-white f-size-xl">
                NFL schedule Week 15: TV coverage, channels, scores for every football game today            </h2><!-- .clr-white.f-size-xl -->
        </div><!-- .page-title -->
        				<div class="featured-image">
			        <img width="1920" height="1080"   alt="NFL schedule Week 15: TV coverage, channels, scores for every football game today" data-srcset="https://www.thehamdenjournal.com/wp-content/uploads/2021/12/NFL-schedule-Week-15-TV-coverage-channels-scores-for-every.jpg 1920w, https://www.thehamdenjournal.com/wp-content/uploads/2021/12/NFL-schedule-Week-15-TV-coverage-channels-scores-for-every-300x169.jpg 300w, https://www.thehamdenjournal.com/wp-content/uploads/2021/12/NFL-schedule-Week-15-TV-coverage-channels-scores-for-every-1024x576.jpg 1024w, https://www.thehamdenjournal.com/wp-content/uploads/2021/12/NFL-schedule-Week-15-TV-coverage-channels-scores-for-every-768x432.jpg 768w, https://www.thehamdenjournal.com/wp-content/uploads/2021/12/NFL-schedule-Week-15-TV-coverage-channels-scores-for-every-1536x864.jpg 1536w, https://www.thehamdenjournal.com/wp-content/uploads/2021/12/NFL-schedule-Week-15-TV-coverage-channels-scores-for-every-800x450.jpg 800w"  data-src="https://www.thehamdenjournal.com/wp-content/uploads/2021/12/NFL-schedule-Week-15-TV-coverage-channels-scores-for-every.jpg" data-sizes="(max-width: 1920px) 100vw, 1920px" class="attachment-full size-full wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="1920" height="1080" src="https://www.thehamdenjournal.com/wp-content/uploads/2021/12/NFL-schedule-Week-15-TV-coverage-channels-scores-for-every.jpg" class="attachment-full size-full wp-post-image" alt="NFL schedule Week 15: TV coverage, channels, scores for every football game today" srcset="https://www.thehamdenjournal.com/wp-content/uploads/2021/12/NFL-schedule-Week-15-TV-coverage-channels-scores-for-every.jpg 1920w, https://www.thehamdenjournal.com/wp-content/uploads/2021/12/NFL-schedule-Week-15-TV-coverage-channels-scores-for-every-300x169.jpg 300w, https://www.thehamdenjournal.com/wp-content/uploads/2021/12/NFL-schedule-Week-15-TV-coverage-channels-scores-for-every-1024x576.jpg 1024w, https://www.thehamdenjournal.com/wp-content/uploads/2021/12/NFL-schedule-Week-15-TV-coverage-channels-scores-for-every-768x432.jpg 768w, https://www.thehamdenjournal.com/wp-content/uploads/2021/12/NFL-schedule-Week-15-TV-coverage-channels-scores-for-every-1536x864.jpg 1536w, https://www.thehamdenjournal.com/wp-content/uploads/2021/12/NFL-schedule-Week-15-TV-coverage-channels-scores-for-every-800x450.jpg 800w" sizes="(max-width: 1920px) 100vw, 1920px" /></noscript>			    </div><!-- .featured-image.thumb.lazyloading -->
								<div class="entry-meta">
	                <ul class="metas">
	                				                    <li class="posted-date clr-special">
			                    	Posted On: <a href="https://www.thehamdenjournal.com/sports/nfl-schedule-week-15-tv-coverage-channels-scores-for-every-football-game-today/1521/" rel="bookmark"><time class="entry-date published updated" datetime="2021-12-19T13:29:17-05:00">December 19, 2021</time></a>					            </li><!-- .posted-date.clr-white -->
					            			                    <li class="author clr-special">
			                    	Posted By: <a href="https://www.thehamdenjournal.com/author/sjytvwkzv4/">Joe Brock</a>			                    </li><!-- .author.clr-white -->
			                    			                	<li class="Comment clr-special">
			                		Comments: <a href="https://www.thehamdenjournal.com/sports/nfl-schedule-week-15-tv-coverage-channels-scores-for-every-football-game-today/1521/">0</a>			                	</li>
			                		                    
	                </ul><!-- .metas -->
	            </div><!-- .entry-meta -->
				        
        <div class="page-contents-entry">
            <div class="editor-entry">
                
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="2296e6f030fbe79da192b5d53584bf33" data-index="1" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-3511443799407499"
     crossorigin="anonymous"></script>
<!-- Hamden -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3511443799407499"
     data-ad-slot="5298334267"
     data-ad-format="auto"
     data-page-url="https://www.thehamdenjournal.com/"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p></p>
<div id="">
<p class="block-element__p">NFL fans are treated to a seemingly longer week of action than they have been in previous weeks.</p>
<p class="block-element__p">There have already been games on two separate days, with the Chiefs beating the Chargers on Thursday, and the Browns-Raiders, Colts-Patriots games taking place on Saturday. Now, it&#8217;s time to get into the meat of the Week 15 slate as the Sunday games roll around.</p>
<p class="block-element__p">In terms of deciding the top of the NFL draft order, there might not be a more high stakes game than the one set to take place Sunday afternoon between the Texans and Jaguars. The two squads are tied with 2-11 records, with Houston holding the tiebreaker for the better record with the head-to-head win in Week 1 of the season.</p>
<p class="block-element__p">For those more interested in the playoff race, two contenders on the outside looking in face off in the later slate with the Bengals traveling to Denver to face the Broncos. That 4 o&#8217;clock window will also feature a highly anticipated clash between Aaron Rodgers and Lamar Jackson with the Packers traveling to Baltimore to face the Ravens.</p>
<p class="block-element__p">The remaining two primetime games will feature divisional showdowns, first in the NFC South with the Saints facing the Buccaneers, and then the NFC North with the Vikings playing the Bears.</p>
<p class="block-element__p">Sporting News has you covered for everything you need to watch Week 15 of the season.</p>
<p class="block-element__p"><strong class="content-element__strong">MORE: <a target="_blank" href="https://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" class="content-element__a" rel="noopener">Watch NFL games live with fuboTV (7-day free trial)</a></strong></p>
<h2 class="block-element__h2">NFL schedule this week: Week 15 TV coverage</h2>
<p class="block-element__p">Here&#8217;s the full schedule for Week 15 of the NFL season, plus final scores and how to watch every game live. </p>
<p class="block-element__p"><em class="content-element__em">Note: national broadcasts are listed in bold</em></p>
<h3 class="block-element__h3">Thursday, Dec. 16</h3>
<div class="content-element__table-container">
<table>
<tbody>
<tr>
<td>Game</td>
<td>Time (ET)</td>
<td>TV Channel</td>
</tr>
<tr>
<td><strong>Chiefs 34, Chargers 28</strong></td>
<td>8:20 p.m.</td>
<td>Fox, NFL Network, <a target="_blank" href="https://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" rel="noopener">fuboTV</a></td>
</tr>
</tbody>
</table>
</div>
<h3 class="block-element__h3">Saturday, Dec. 18</h3>
<div class="content-element__table-container">
<table>
<tbody>
<tr>
<td>Game</td>
<td>Time (ET)</td>
<td>Channel</td>
</tr>
<tr>
<td><strong>Patriots at Colts</strong></td>
<td>8:15 p.m.</td>
<td>NFL Network, <a target="_blank" href="https://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" rel="noopener">fuboTV</a></td>
</tr>
</tbody>
</table>
</div>
<h3 class="block-element__h3">Sunday, Dec. 19</h3>
<div class="content-element__table-container">
<table>
<tbody>
<tr>
<td>Game</td>
<td>Time (ET)</td>
<td>Channel</td>
</tr>
<tr>
<td>Panthers at Bills</td>
<td>1:00 p.m.</td>
<td>Fox, <a target="_blank" href="https://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" rel="noopener">fuboTV</a></td>
</tr>
<tr>
<td>Cardinals at Lions</td>
<td>1:00 p.m.</td>
<td>Fox, <a target="_blank" href="https://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" rel="noopener">fuboTV</a></td>
</tr>
<tr>
<td>Jets at Dolphins</td>
<td>1:00 p.m.</td>
<td>CBS, <a target="_blank" href="https://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" rel="noopener">fuboTV</a></td>
</tr>
<tr>
<td>Cowboys at Giants</td>
<td>1:00 p.m.</td>
<td>Fox, <a target="_blank" href="https://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" rel="noopener">fuboTV</a></td>
</tr>
<tr>
<td>Titans at Steelers</td>
<td>1:00 p.m.</td>
<td>CBS, <a target="_blank" href="https://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" rel="noopener">fuboTV</a></td>
</tr>
<tr>
<td>Texans at Jaguars</td>
<td>1:00 p.m.</td>
<td>CBS, <a target="_blank" href="https://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" rel="noopener">fuboTV</a></td>
</tr>
<tr>
<td>Bengals at Broncos</td>
<td>4:05 p.m.</td>
<td>CBS, <a target="_blank" href="https://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" rel="noopener">fuboTV</a></td>
</tr>
<tr>
<td>Falcons at 49ers</td>
<td>4:05 p.m.</td>
<td>CBS, <a target="_blank" href="https://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" rel="noopener">fuboTV</a></td>
</tr>
<tr>
<td>Packers at Ravens</td>
<td>4:25 p.m.</td>
<td>Fox, <a target="_blank" href="https://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" rel="noopener">fuboTV</a></td>
</tr>
<tr>
<td><strong>Saints at Buccaneers</strong></td>
<td>8:20 p.m.</td>
<td>NBC, <a target="_blank" href="https://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" rel="noopener">fuboTV</a></td>
</tr>
</tbody>
</table>
</div>
<h3 class="block-element__h3">Monday, Dec. 20</h3>
<div class="content-element__table-container">
<table>
<tbody>
<tr>
<td>Game</td>
<td>Time (ET)</td>
<td>Channel</td>
</tr>
<tr>
<td>Raiders at Browns</td>
<td>5:00 p.m.</td>
<td>NFL Network, <a target="_blank" href="http://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" rel="noopener">fuboTV</a></td>
</tr>
<tr>
<td><strong>Vikings at Bears</strong></td>
<td>8:15 p.m.</td>
<td>ESPN, <a target="_blank" href="https://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" rel="noopener">fuboTV</a></td>
</tr>
</tbody>
</table>
</div>
<h3 class="block-element__h3">Tuesday, Dec. 21</h3>
<div class="content-element__table-container">
<table>
<tbody>
<tr>
<td>Game</td>
<td>Time (ET)</td>
<td>Channel</td>
</tr>
<tr>
<td>Seahawks at Rams</td>
<td>7:00 p.m.</td>
<td>Fox, <a target="_blank" href="http://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" rel="noopener">fuboTV</a></td>
</tr>
<tr>
<td>Washington at Eagles</td>
<td>7:00 p.m.</td>
<td>Fox, <a target="_blank" href="http://www.fubo.tv/lp/football/?bgvideo=nfl.mp4&amp;title=Live%20Football.%20Stream%20and%20DVR.&amp;priceline=*Regional%20and%20mobile%20restrictions%20apply&amp;cta=Get%207-Day%20Free%20Trial%20Now&amp;irad=356362&amp;irmp=1131770&amp;sharedid=editorial" rel="noopener">fuboTV</a></td>
</tr>
</tbody>
</table>
</div>
<h2 class="block-element__h2">How to watch NFL games in Week 15</h2>
<p class="block-element__p">This is the first week that there will be several games being aired on prime time. The Chiefs and Chargers already played on Thursday, and the Browns-Raiders, Patriots-Colts games wrapped up on Saturday. The next primetime matchups will be the Saints vs. Buccaneers on &#8220;Sunday Night Football&#8221; on NBC, and the Vikings will face the Bears on &#8220;Monday Night Football&#8221; on ESPN and ABC to wrap up Week 15.</p>
<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="2296e6f030fbe79da192b5d53584bf33" data-index="2" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-3511443799407499"
     crossorigin="anonymous"></script>
<!-- Hamden -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3511443799407499"
     data-ad-slot="5298334267"
     data-ad-format="auto"
     data-page-url="https://www.thehamdenjournal.com/"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>

<p class="block-element__p">The rest of the slate will be aired either on CBS or FOX. Check your local listings to see which games will be on your broadcast.</p>
<p class="block-element__p">Canadian viewers can find the games on TSN, CTV and CTV2, and <a target="_blank" href="http://prf.hn/click/camref:1100lfPvV/pubref:TextLinks" class="content-element__a" rel="noopener">stream every game on DAZN</a>.</p>
<h2 class="block-element__h2">NFL scores Week 15</h2>
<h3 class="block-element__h3">Thursday, Dec. 16</h3>
<div class="content-element__table-container">
<table>
<tbody>
<tr>
<td>Game</td>
<td>Score</td>
</tr>
<tr>
<td>Chiefs at Chargers</td>
<td>34-28, KC</td>
</tr>
</tbody>
</table>
</div>
<h3 class="block-element__h3">Saturday, Dec. 18</h3>
<div class="content-element__table-container">
<table>
<tbody>
<tr>
<td>Game</td>
<td>Score</td>
</tr>
<tr>
<td>Patriots at Colts</td>
<td>&#8212;</td>
</tr>
</tbody>
</table>
</div>
<h3 class="block-element__h3">Sunday, Dec. 19</h3>
<div class="content-element__table-container">
<table>
<tbody>
<tr>
<td>Game</td>
<td>Score</td>
</tr>
<tr>
<td>Panthers at Bills</td>
<td>&#8212;</td>
</tr>
<tr>
<td>Cardinals at Lions</td>
<td>&#8212;</td>
</tr>
<tr>
<td>Jets at Dolphins</td>
<td>&#8212;</td>
</tr>
<tr>
<td>Cowboys at Giants</td>
<td>&#8212;</td>
</tr>
<tr>
<td>Titans at Steelers</td>
<td>&#8212;</td>
</tr>
<tr>
<td>Texans at Jaguars</td>
<td>&#8212;</td>
</tr>
<tr>
<td>Bengals at Broncos</td>
<td>&#8212;</td>
</tr>
<tr>
<td>Falcons at 49ers</td>
<td>&#8212;</td>
</tr>
<tr>
<td>Packers at Ravens</td>
<td>&#8212;</td>
</tr>
<tr>
<td>Saints at Buccaneers</td>
<td>&#8212;</td>
</tr>
</tbody>
</table>
</div>
<h3 class="block-element__h3">Monday, Dec. 20</h3>
<div class="content-element__table-container">
<table>
<tbody>
<tr>
<td>Game</td>
<td>Score</td>
</tr>
<tr>
<td>Raiders at Browns</td>
<td>&#8212;</td>
</tr>
<tr>
<td>Vikings at Bears</td>
<td>&#8212;</td>
</tr>
</tbody>
</table>
</div>
<h3 class="block-element__h3">Tuesday, Dec. 21</h3>
<div class="content-element__table-container">
<table>
<tbody>
<tr>
<td>Game</td>
<td>Score</td>
</tr>
<tr>
<td>Seahawks at Rams</td>
<td>&#8212;</td>
</tr>
<tr>
<td>Washington at Eagles</td>
<td>&#8212;</td>
</tr>
</tbody>
</table>
</div></div>

<!-- Quick Adsense WordPress Plugin: http://quickadsense.com/ -->
<div class="2296e6f030fbe79da192b5d53584bf33" data-index="3" style="float: none; margin:10px 0 10px 0; text-align:center;">
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-3511443799407499"
     crossorigin="anonymous"></script>
<!-- Hamden -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3511443799407499"
     data-ad-slot="5298334267"
     data-ad-format="auto"
     data-page-url="https://www.thehamdenjournal.com/"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
<p><script type="text/plain" class="optanon-category-C0004">
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window,document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', 235247967118144);
  fbq('track', 'PageView');
</script></p>

<div style="font-size: 0px; height: 0px; line-height: 0px; margin: 0; padding: 0; clear: both;"></div><div id="author-bio-box" style="background: #f8f8f8; border-top: 2px solid #cccccc; border-bottom: 2px solid #cccccc; color: #333333"><h3><a style="color: #555555;" href="https://www.thehamdenjournal.com/author/sjytvwkzv4/" title="All posts by Joe Brock" rel="author">Joe Brock</a></h3><div class="bio-gravatar"><img width="70" height="70"   alt="" data-srcset="https://www.thehamdenjournal.com/wp-content/uploads/2021/12/11-150x150.jpg 150w, https://www.thehamdenjournal.com/wp-content/uploads/2021/12/11-300x300.jpg 300w, https://www.thehamdenjournal.com/wp-content/uploads/2021/12/11-768x768.jpg 768w, https://www.thehamdenjournal.com/wp-content/uploads/2021/12/11.jpg 1024w"  data-src="https://www.thehamdenjournal.com/wp-content/uploads/2021/12/11-150x150.jpg" data-sizes="(max-width: 70px) 100vw, 70px" class="avatar avatar-70 photo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="70" height="70" src="https://www.thehamdenjournal.com/wp-content/uploads/2021/12/11-150x150.jpg" class="avatar avatar-70 photo" alt="" srcset="https://www.thehamdenjournal.com/wp-content/uploads/2021/12/11-150x150.jpg 150w, https://www.thehamdenjournal.com/wp-content/uploads/2021/12/11-300x300.jpg 300w, https://www.thehamdenjournal.com/wp-content/uploads/2021/12/11-768x768.jpg 768w, https://www.thehamdenjournal.com/wp-content/uploads/2021/12/11.jpg 1024w" sizes="(max-width: 70px) 100vw, 70px" /></noscript></div><a target="_blank" rel="nofollow noopener noreferrer" href="https://www.thehamdenjournal.com" class="bio-icon bio-icon-website"></a><p class="bio-description">Joe founded The Hamden Journal with an aim to bring relevant and unaltered news to the general public with a specific view point for each story catered by the team. He is a proficient journalist who holds a reputable portfolio with proficiency in content analysis and research. With ample knowledge about the business industry, Joe also contributes his knowledge for the business section of the website.</p></div>            </div><!-- .editor-entry -->
        </div><!-- .page-contents-entry -->
    </article>
</section><!-- .en-page-entry.post-page-entry.post-page-layout-1 -->
	<nav class="navigation post-navigation" role="navigation" aria-label="Posts">
		<h2 class="screen-reader-text">Post navigation</h2>
		<div class="nav-links"><div class="nav-previous"><a href="https://www.thehamdenjournal.com/entertainment/riverdale-star-casey-cott-marries-nichola-basara/1519/" rel="prev">Prev Post</a></div><div class="nav-next"><a href="https://www.thehamdenjournal.com/sports/how-rangers-are-preparing-next-wave-of-top-prospects-for-nhl/1523/" rel="next">Next Post</a></div></div>
	</nav>                    </main><!-- #main.site-main -->
                </div><!-- #primary.content-area -->
            </div><!-- .en-col main-content-area-outer -->
            <div class="en-col aside-sidebar-outer aside-right-outer ">
    <aside class="secondary">
        <div id="text-2" class="widget"><div class="widget_text"><div class="widget-title"><h3>Ads by Google</h3></div>			<div class="textwidget"><p><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js?client=ca-pub-3511443799407499"
     crossorigin="anonymous"></script><br />
<!-- Hamden --><br />
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-3511443799407499"
     data-ad-slot="5298334267"
     data-ad-format="auto"
     data-page-url="https://www.thehamdenjournal.com/"
     data-full-width-responsive="true"></ins><br />
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</div>
		</div></div>    </aside><!-- .secondary -->
</div><!-- .en-col aside-sidebar-outer -->        </div><!-- .row -->
    </div><!-- .en-container -->
</div><!-- .en-inner-pages-main-wrapper -->

		<footer class="footer">
            <div class="footer-inner">
                <div class="en-container">
                                        <div class="bottom-footer">
                        <div class="row">
                                                        <div class="col-lg-6 col-md-6 col-sm-12">
                                <div class="copyright-notice">
                                    <p>
                                        The Hamden Journal by <a href="https://everestthemes.com">Everestthemes</a>                                    </p>
                                </div>
                            </div><!-- .col -->
                                                            <div class="col-lg-6 col-md-6 col-sm-12">
                                    <div class="footer-navigation">
                                        <ul id="menu-about-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-159"><a href="https://www.thehamdenjournal.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-110"><a href="https://www.thehamdenjournal.com/about-us/">About Us</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-113"><a href="https://www.thehamdenjournal.com/team-members/">Team Members</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7"><a href="https://www.thehamdenjournal.com/contact/">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-109"><a href="https://www.thehamdenjournal.com/privacy-policy/">Privacy Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-111"><a href="https://www.thehamdenjournal.com/cookie-policy/">Cookie Policy</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-112"><a href="https://www.thehamdenjournal.com/editorial-policy/">Editorial Policy</a></li>
</ul>                                    </div>
                                </div><!-- .col -->
                                                        </div><!-- .row -->
                    </div><!-- .bottom-footer -->
                </div><!-- .en-container -->
            </div><!-- .footer-inner -->
        </footer><!-- .footer -->
    </div><!-- .en-pagewrap -->
    
<script type="text/javascript">var jQueryScriptOutputted = false;function initJQuery() {if (typeof(jQuery) == "undefined") {if (!jQueryScriptOutputted) {jQueryScriptOutputted = true;document.write("<scr" + "ipt type=\"text/javascript\" src=\"https://code.jquery.com/jquery-1.8.2.min.js\"></scr" + "ipt>");}setTimeout("initJQuery()", 50);}}initJQuery();</script><script type="text/javascript">jQuery(document).ready(function() {
jQuery(".2296e6f030fbe79da192b5d53584bf33").click(function() {
jQuery.post(
"https://www.thehamdenjournal.com/wp-admin/admin-ajax.php", {
"action": "quick_adsense_onpost_ad_click",
"quick_adsense_onpost_ad_index": jQuery(this).attr("data-index"),
"quick_adsense_nonce": "2e5f07f5cd",
}, function(response) { }
);
});
});
</script><link rel='stylesheet' id='author-bio-box-styles-css'  href='https://www.thehamdenjournal.com/wp-content/plugins/author-bio-box/assets/css/author-bio-box.css?ver=3.4.1' type='text/css' media='all' />
<script type='text/javascript' src='https://www.thehamdenjournal.com/wp-content/plugins/metronet-profile-picture/js/mpp-frontend.js?ver=2.6.0' id='mpp_gutenberg_tabs-js'></script>
<script type='text/javascript' src='https://www.thehamdenjournal.com/wp-includes/js/imagesloaded.min.js?ver=4.1.4' id='imagesloaded-js'></script>
<script type='text/javascript' src='https://www.thehamdenjournal.com/wp-includes/js/masonry.min.js?ver=4.2.2' id='masonry-js'></script>
<script type='text/javascript' src='https://www.thehamdenjournal.com/wp-content/themes/everest-news/assets/dist/js/bundle.min.js?ver=1.0.8' id='everest-news-bundle-js'></script>
<script type='text/javascript' src='https://www.thehamdenjournal.com/wp-content/plugins/wp-smushit/app/assets/js/smush-lazy-load.min.js?ver=3.9.2' id='smush-lazy-load-js'></script>
<script type='text/javascript' src='https://www.thehamdenjournal.com/wp-includes/js/wp-embed.min.js?ver=5.8.2' id='wp-embed-js'></script>
</body>
</html>

